差分

この文書の現在のバージョンと選択したバージョンの差分を表示します。

この比較画面にリンクする

両方とも前のリビジョン 前のリビジョン
次のリビジョン
前のリビジョン
programming:python:start [2012/02/10 00:44]
yuki
programming:python:start [2012/03/01 22:39] (現在)
yuki
ライン 1: ライン 1:
 ====== Python ====== ====== Python ======
 +
 +===== パッケージ管理 =====
 +
 +  * setup.pyを使う(パッケージングされたファイル郡に含まれていれば)
 +    * <​code>​python setup.py install</​code>​
 +  * easy_install
 +    * apt-get install python-setuptools
 +    * proxyはここで指定
 +      * <​code>​export http_proxy=http://​example.com:​8080
 +export https_proxy=http://​example.com:​8080</​code>​
 +  * pip
 +    * apt-get install python-pip
 +      * バージョン低すぎて、uninstall出来ないとかなるので、easy_install推奨。
 +    * easy_install pip
 +    * proxyは、pip install <<​package-name>>​ --proxy=http://​example.com:​8080
  
 ===== ライブラリ ===== ===== ライブラリ =====
ライン 19: ライン 34:
       * http://​zetcode.com/​wxpython/​       * http://​zetcode.com/​wxpython/​
  
-  * [[.:​sphinx:​]]+===== Document =====
  
 +  * [[.:​sphinx:​]]
 +    * 自動化の仕組みを作ると尚良い。
  
 ===== Develop ===== ===== Develop =====
ライン 30: ライン 47:
       * 小さめのスクリプトをクイックスタート       * 小さめのスクリプトをクイックスタート
         * PyScripter         * PyScripter
-      ​GUIもやるなら何がいいんろうね。今のところPyScripterでwxPythonもそんな悪くない。良くもないけど。 +          ​し、スクリプトパス2バイト文字があると、"​UnicodeEncodeError:​ '​ascii'​ codec can't encode characters"​ とか言われる 
-        * PySideが情報量もあって使いやすい。+          * http://​code.google.com/​p/​pyscripter/​issues/​detail?​id=427 
 +      * Visual Studio 2010に上乗せ 
 +        * http://​pytools.codeplex.com/​ 
 +          * 要 : Microsoft Visual Studio 2010 Shell (Integrated) 
 +          * http://​www.microsoft.com/​download/​en/​details.aspx?​id=115
  
   * 独立環境   * 独立環境
     * virtualenv     * virtualenv
-      * pip install  +      * pip install ​virtualenv 
- +      使う時は、以下をセトで。 
-  ​ケージ管理 +        <​code>​virtualenv project-name --no-site-packages 
-    easy_install +source ./project-name/bin/​activate 
-      * apt-get install python-setuptools +# ホスト名に(project-name)が付たらOK 
-      * proxyは、export http_proxy=http:​//example.com:​8080 した後で。 +deactivate 
-    * pip +# これで抜ける</code>
-      * apt-get install python-pip +
-        * バージョン低すぎて、uninstall出来なとかなるので、easy_install推奨。 +
-      * easy_install pip +
-      * proxyは、pip install ​<<​package-name>> --proxy=http://​example.com:​8080+
  
   * ライブラリのコンパイル   * ライブラリのコンパイル
programming/python/start.1328802288.txt.gz · 最終更新: 2012/02/10 00:44 by yuki
CC Attribution-Noncommercial-Share Alike 4.0 International
Driven by DokuWiki Recent changes RSS feed Valid CSS Valid XHTML 1.0