pdoc 0.1 documentation

mod_wsgi

«  e-accelerator   ::   Contents   ::   apache proxy + usermin  »

mod_wsgi

WSGIに従って動作する
http://modwsgi.googlecode.com/

Install

Ubuntu 10.04では以下のように導入する

# apt-get install libapache2-mod-wsgi

しかし、環境によっては、以下のようなエラー頻発する。 (Ubuntu 10.04のaptで入る、apche2 2.2.14 + python2.6 + libapache2-mod-wsgi 2.8 とか)

[error] Exception KeyError: KeyError(140162412959552,)
in <module 'threading' from '/usr/lib/python2.6/threading.pyc'> ignored

以下のように作り直す

# wget http://modwsgi.googlecode.com/files/mod_wsgi-3.3.tar.gz
# tar zxvf mod_wsgi-3.3.tar.gz
# cd mod_wsgi-3.3
# ./configure
# make
# make install
# cd /etc/apache2/sites-enable
# echo 'LoadModule wsgi_module /usr/lib/apache2/modules/mod_wsgi.so' > mod_wsgi.load
# service apache2 restart

./configure中にapxs/apxs2が無いと言われる場合

# apt-get install apache2-threaded-dev

make中にpython.hが無いと言われる場合

# apt-get install python-dev

Table Of Contents

Previous topic

e-accelerator

Next topic

apache proxy + usermin

This Page

«  e-accelerator   ::   Contents   ::   apache proxy + usermin  »