FreeBSDでpkgのメッセージが二重にURIエンコードされてて、盛大に勘違いした

FreeBSD 10.1-RELEASE-p16にpkgからOpenLDAPを入れて認証基盤にしようとしたところ、:

/usr/local/etc/rc.d/slapd: WARNING: slapd: Can't find socket /var/run/openldap/ldapi

なるWARNINGが止まらなかったのだけど、そう設定しろって言ってくるpkgのバグだってことが分かるまでのお話。

more…