コンテンツにスキップ

Openindiana

Opensolarisの後継プロジェクト。

Fail

書いてた当時はoi_151aとかその辺り

Install

USBメモリからインストール

  • USB用イメージの取得
    • "oi-dev-151a-text-x86.usb"ってやつね。
  • OsolLiveUSBを使ってUSBメモリに焼きこみ
  • 後は挿して起動していつも通り
  • でも何か安定しなくて超困る。
    • 何故かUSBメモリでブートさせて、同時にDVDも入れておくと正常にインストール終わるとか、意味分からん。
    • GT110bの場合はシリアルコンソールリダイレクションを有効にしてると、USBメモリから起動しないっぽい。
    • TX100 S3の場合はUEFIがデフォルトでdisableなんだけどenableにしたら動いたとか。

Update

OpenIndianaのイメージアップデート周り。

  • 本家説明
  • このへんのpdf見たほうがいいかも

  • アップデートリポジトリの確認: # pkg publisher

  • アップデートリポジトリの追加: # pkg set-publisher -O http://pkg.openindiana.org/dev/ openindiana.org
  • アップデートリポジトリの削除: # pkg unset-publisher opensolaris.org
  • アップデートの実行: # pkg image-update -v

    • "-v"は詳細モード。別にいらない。
    • "-n"をつけると仮実行。いきなり適用が怖い時は先にこっち。: # pkg image-update -nv
  • 起動イメージの確認

    # beadm list
    BE        Active Mountpoint Space   Policy Created
    --        ------ ---------- -----   ------ -------
    solaris   -      -          6.17M   static 2011-02-06 02:25
    solaris-1 -      -          208.49M static 2011-04-12 22:35
    solaris-2 N      /          106.5K  static 2011-04-12 22:38
    solaris-3 R      -          4.56G   static 2011-08-16 21:24
    

    • Nが今の、Rが次回起動時。過去の-1とか消していいのかよくわかんねぇ。
    • BE = Boot Environmentな。
  • pkg自体のバージョンが低いと、そっちを先に上げろと言われる
    # pkg image-update -nv
    WARNING: pkg(5) appears to be out of date, and should be updated before
    running image-update.  Please update pkg(5) using 'pfexec pkg install
    pkg:/package/pkg' and then retry the image-update.
    
    • 先にアップデートする
      # pfexec pkg install pkg:/package/pkg
                      Packages to update:     1
              Create boot environment:    No
                  Services to restart:     1
      DOWNLOAD                                  PKGS       FILES    XFER (MB)
      Completed                                  1/1     126/126      0.7/0.7
      
      PHASE                                        ACTIONS
      Install Phase                                    1/1
      Update Phase                                 241/241
      
      PHASE                                          ITEMS
      Package State Update Phase                       2/2
      Package Cache Update Phase                       1/1
      Image State Update Phase                         2/2
      
    • その後改めてアップデート
      # pkg image-update -nv
      # pkg image-update -v
      

Configuration

IPの設定(ipadm)

まず対象のI/Fを見つける

# ipadm show-if
IFNAME     STATE    CURRENT      PERSISTENT
lo0        ok       -m-v------46 ---
nxge0      down     bm--------46 -46
  • 設定がないと見つからないかもしれないので、"dmesg | grep link"の方がいいかも...

ipadmで設定

ipadm create-addr -T static -a 192.168.1.176/24 nxge0/v4static
ipadm create-addr -T addrconf nxge0/v6auto
ipadm create-addr -T static -a 2001:380:e08:f7::176/64 nxge0/v6static
  • "-T addrconf"を使って、一度リンクローカルアドレスを付与してからでないと、静的IPが振れない?
    • 初回はaddrconfだと言っているのにDHCPv6が起動する(RAでMフラグつけてる時)。
    • 以下のように消してからもう一度付け直すと、RAによるアドレスのみになる。
      # ipadm show-addr | grep nxge
      nxge0/v4static    static   ok           192.168.1.176/24
      nxge0/v6auto      addrconf ok           fe80::214:4fff:fe6d:3fa8/10
      nxge0/?           addrconf ok           2001:380:e08:f7:214:4fff:fe6d:3fa8/64
      nxge0/v6auto      addrconf ok           2001:380:e08:f7::6:bd/128
      nxge0/v6static    static   ok           2001:380:e08:f7::176/64
      # ipadm delete-addr nxge0/v6auto
      # ipadm show-addr | grep nxge
      nxge0/v4static    static   ok           192.168.1.176/24
      nxge0/?           dhcp     down         ?
      nxge0/v6static    static   ok           2001:380:e08:f7::176/64
      # ipadm create-addr -T addrconf nxge0/v6auto
      # ipadm show-addr | grep ncge
      nxge0/v4static    static   ok           192.168.1.176/24
      nxge0/v6auto      addrconf ok           fe80::214:4fff:fe6d:3fa8/10
      nxge0/v6auto      addrconf ok           2001:380:e08:f7:214:4fff:fe6d:3fa8/64
      nxge0/v6static    static   ok           2001:380:e08:f7::176/64
      
    • でも再起動したらやっぱり元通り。
    • http://hub.opensolaris.org/bin/view/Project+brussels/ifconfig_ipadm_feature_mapping

IPv6固有の話

IPの設定(svcadm)

  • dnet0の部分は、I/F名を入れる。nxge0とかe1000g0とか。
    svcadm disable physical:nwam
    svcadm enable physical:default
    echo "addif 2001:380:e08:e7::176/64 up" > /etc/hostname6.dnet0
    echo "192.168.1.176 netmask 255.255.255.0" > /etc/hostname.dnet0
    svcadm restart physical:default
    

Routeの設定

  • デフォルトゲートウェイ
    # route -p add default 192.168.1.1
    # route -p show
    persistent: route add default 192.168.1.1
    

DNS(resolver)の設定

  • デフォルトだとDNSを参照しないので、vi /etc/nsswitch.confして、hostsの参照をfiles dnsに。
echo "nameserver 192.168.1.1" >> /etc/resolv.conf
echo "domain example.com" >> /etc/resolv.conf
echo "search example.com" >> /etc/resolv.conf

LACPを使用することを前提に設定する。

構成:

OpenIndiana Procurve 1810G-24
e1000g0 - Port 10
e1000g1 - Port 12

設定

# dladm create-aggr -d e1000g0 -d e1000g1
# dladm modify-aggr -L active aggr1
  • 恐らくaggr1生成時点では、LACPはoffになっているので、モードをLACP Activeにする。
  • インタフェース作成後は、普段同様に[[..:ip:|IPの設定]]を行う。

確認

# dladm show-aggr -x
LINK        PORT           SPEED DUPLEX   STATE     ADDRESS            PORTSTATE
aggr1       --             1000Mb full    up        0:19:99:ae:64:39   --
            e1000g1        1000Mb full    up        0:19:99:ae:64:39   attached
            e1000g0        1000Mb full    up        0:19:99:b2:b0:4f   attached
# dladm show-aggr -P
LINK            POLICY   ADDRPOLICY           LACPACTIVITY  LACPTIMER   FLAGS
aggr1           L4       auto                 active        short       -----
# dladm show-aggr -L
LINK        PORT         AGGREGATABLE SYNC COLL DIST DEFAULTED EXPIRED
aggr1       e1000g1      yes          yes  yes  yes  no        no
--          e1000g0      yes          yes  yes  yes  no        no

SSHの設定

SSHの有効化: svcadm enable ssh

NTPの設定

  • Oracleの設定と同様

  • パッケージが入って無ければ入れる: # pkg install network/ntp

  • /etc/inet/ntp.conf を準備する。ntp.clientを雛形として使用。
    # cd /etc/inet
    # cp ntp.client ntp.conf
    # vi ntp.conf
    # svcadm enable network/ntp
    # ntpq -p
         remote           refid      st t when poll reach   delay   offset  jitter
    ==============================================================================
    *nazuna.ainoniwa 202.234.233.106  4 u   46   64  377    0.294  -14.648   4.141
    

HDDデバイスの管理

  • デバイスの再認識: # devfsadm
  • 認識済みのHDD確認
    # cfgadm -al
    Ap_Id                          Type         Receptacle   Occupant     Condition
    c3                             scsi-sas     connected    configured   unknown
    c3::dsk/c3t1d0                 disk         connected    configured   unknown
    usb8/1                         usb-hub      connected    configured   ok
    usb8/1.1                       unknown      empty        unconfigured ok
    usb8/1.2                       unknown      empty        unconfigured ok
    usb8/1.3                       unknown      empty        unconfigured ok
    usb8/1.4                       unknown      empty        unconfigured ok
    usb8/1.5                       unknown      empty        unconfigured ok
    usb8/1.6                       unknown      empty        unconfigured ok
    usb8/2                         unknown      empty        unconfigured ok
    usb9/1                         usb-hub      connected    configured   ok
    usb9/1.1                       unknown      empty        unconfigured ok
    usb9/1.2                       unknown      empty        unconfigured ok
    usb9/1.3                       unknown      empty        unconfigured ok
    usb9/1.4                       unknown      empty        unconfigured ok
    usb9/1.5                       unknown      empty        unconfigured ok
    usb9/1.6                       usb-device   connected    configured   ok
    usb9/1.7                       unknown      empty        unconfigured ok
    usb9/1.8                       unknown      empty        unconfigured ok
    usb9/2                         unknown      empty        unconfigured ok
    

COMSTAR

  • 動作確認時のパケットキャプチャ

iSCSI on zvol

  • pkgのインストール
    # pkg search iscsi
    # pkg install pkg:/network/iscsi/target
    
  • サービスの起動
    # svcadm enable -r svc:/network/iscsi/target:default
    # svcadm enable stmf
    # svcs -a | grep iscsi
    online          2月_27 svc:/network/iscsi/initiator:default
    online          2月_27 svc:/network/iscsi/target:default
    
  • zvolの作成
    # zfs create -V 10g m-test/iscsi
    
  • COMSTARのLU作成→VIEWに追加→Targetの作成

    # sbdadm create-lu /dev/zvol/rdsk/m-test/iscsi 
    Created the following LU:
    
                GUID                    DATA SIZE           SOURCE
    --------------------------------  -------------------  ----------------
    600144f06286850000004d68c01b0002  10737418240          /dev/zvol/rdsk/m-test/iscsi
    # sbdadm list-lu
    
    Found 1 LU(s)
    
                GUID                    DATA SIZE           SOURCE
    --------------------------------  -------------------  ----------------
    600144f06286850000004d68c01b0002  10737418240          /dev/zvol/rdsk/m-test/iscsi
    # stmfadm list-lu
    LU Name: 600144F06286850000004D68C01B0002
    # stmfadm add-view 600144f06286850000004d68c01b0002
    # itadm create-target
    View Entry: 0
        Host group   : All
        Target group : All
        LUN          : 0
    # itadm list-target -v
    TARGET NAME                                                  STATE    SESSIONS 
    iqn.1986-03.com.sun:02:97378251-0dc8-c32c-952d-8dfb284ee763  online   0        
            alias:                  -
            auth:                   none (defaults)
            targetchapuser:         -
            targetchapsecret:       unset
            tpg-tags:               default
    

  • メモ

    • 普通やらないと思うけど、COMSTARのiSCSIに接続するホストのiSCSIイニシエータ名は、iqnかEUI形式でなければならない。istgtは特に気にしなくてもいいんだけど、COMSTARではこれに気をつけないとターゲットエラーとなる。
    • manにも書いてあるっぽい?
      iSCSI Initiator Node Contexts
       Certain operations such as authentication by means of  Chal-
       lenge   Handshake  Authentication  Protocol  (CHAP)  require
       parameters associated with a remote  iSCSI  Initiator  Node.
       These parameters are associated with an iSCSI Initiator Node
       Context. An iSCSI Initiator Node Context  is  identified  by
       its Initiator Node Name, formatted in either IQN or EUI for-
       mat (see RFC 3720). For example:
      
         iqn.1986-03.com.sun:01:e00000000000.47d55444
         eui.02004567A425678D
      
  • 参考

sharesmbを使用したsamba

  • ZFSのsharesmbを使用すると、samba公開が簡単にできるよ。簡単だよ、ってだけです。
    • 設定(ZFSパーティションはあると言う前提で)
      # zfs set sharesmb=on dup-test/rec
      # echo "other password required pam_smb_passwd.so.1 nowarn" >> /etc/pam.conf
      # passwd username
      
    • usernameでログインできるはず。
    • 確認用
      # sharemgr show -vp -vpw -vp
      default nfs=()
      zfs
          zfs/dup-test/rec smb=()
              dup-test=/dup-test/rec
      smb smb=()
              * /var/smb/cvol  smb=() ""
                      c$=/var/smb/cvol       smb=(abe="false" guestok="false")      "Default Share"
      
  • 答え

DTrace

Solaris由来のシステムプローブ。

smartctl

  • Solaris系のS.M.A.R.TはATAコマンド叩けない。
  • AHCIならできる。IDE互換だと無理。諦めましょう。

インストール & 動作確認

  • smartctlのコンパイル
    # pkg install gcc-dev
    # wget http://sourceforge.net/projects/smartmontools/files/smartmontools/5.40/smartmontools-5.40.tar.gz/download
    # tar zxvf smartmontools-5.40.tar.gz
    # cd smartmontools-5.40
    # ./configure && make
    # make install
    
  • 検索したら引っかかった: http://cafenate.wordpress.com/2009/02/22/setting-up-smartmontools-on-opensolaris/
  • SASカードであるところの[[:device:sata:br10i:|BR10i]]にぶら下がっているHDDに向けて使ってみる。-T permissive つけた方が表示速度的に良いかも。

    # ./smartctl -T permissive -s on /dev/rdsk/c3t1d0p0
    # ./smartctl -a /dev/rdsk/c3t1d0p0
    smartctl 5.40 2010-10-16 r3189 [i386-pc-solaris2.11] (local build)
    Copyright (C) 2002-10 by Bruce Allen, http://smartmontools.sourceforge.net
    
    === START OF INFORMATION SECTION ===
    Model Family:     Hitachi Travelstar 7K500
    Device Model:     Hitachi HTS725050A9A364
    Serial Number:    101207PCK404GLG45G5J
    Firmware Version: PC4OC70E
    User Capacity:    500,107,862,016 bytes
    Device is:        In smartctl database [for details use: -P show]
    ATA Version is:   8
    ATA Standard is:  ATA-8-ACS revision 6
    Local Time is:    Sun Feb  6 15:15:43 2011 JST
    SMART support is: Available - device has SMART capability.
    SMART support is: Enabled
    
    
    Error SMART Thresholds Read failed: I/O error
    Smartctl: SMART Read Thresholds failed.
    
    === START OF READ SMART DATA SECTION ===
    SMART overall-health self-assessment test result: PASSED
    
    General SMART Values:
    Offline data collection status:  (0x00) Offline data collection activity
                                            was never started.
                                            Auto Offline Data Collection: Disabled.
    Self-test execution status:      (   0) The previous self-test routine completed
                                            without error or no self-test has ever
                                            been run.
    Total time to complete Offline
    data collection:                 ( 645) seconds.
    Offline data collection
    capabilities:                    (0x5b) SMART execute Offline immediate.
                                            Auto Offline data collection on/off support.
                                            Suspend Offline collection upon new
                                            command.
                                            Offline surface scan supported.
                                            Self-test supported.
                                            No Conveyance Self-test supported.
                                            Selective Self-test supported.
    SMART capabilities:            (0x0003) Saves SMART data before entering
                                            power-saving mode.
                                            Supports SMART auto save timer.
    Error logging capability:        (0x01) Error logging supported.
                                            General Purpose Logging supported.
    Short self-test routine
    recommended polling time:        (   2) minutes.
    Extended self-test routine
    recommended polling time:        ( 131) minutes.
    SCT capabilities:              (0x003d) SCT Status supported.
                                            SCT Error Recovery Control supported.
                                            SCT Feature Control supported.
                                            SCT Data Table supported.
    
    SMART Attributes Data Structure revision number: 16
    Vendor Specific SMART Attributes with Thresholds:
    ID# ATTRIBUTE_NAME          FLAG     VALUE WORST THRESH TYPE      UPDATED  WHEN_FAILED RAW_VALUE
      1 Raw_Read_Error_Rate     0x000b   100   100   062    Pre-fail  Always       -       0
      2 Throughput_Performance  0x0005   100   100   040    Pre-fail  Offline      -       0
      3 Spin_Up_Time            0x0007   100   100   033    Pre-fail  Always       -       2
      4 Start_Stop_Count        0x0012   100   100   000    Old_age   Always       -       3
      5 Reallocated_Sector_Ct   0x0033   100   100   005    Pre-fail  Always       -       0
      7 Seek_Error_Rate         0x000b   100   100   067    Pre-fail  Always       -       0
      8 Seek_Time_Performance   0x0005   100   100   ---    Pre-fail  Offline      -       0
      9 Power_On_Hours          0x0012   100   100   ---    Old_age   Always       -       0
     10 Spin_Retry_Count        0x0013   100   100   ---    Pre-fail  Always       -       0
     12 Power_Cycle_Count       0x0032   100   100   ---    Old_age   Always       -       3
    191 G-Sense_Error_Rate      0x000a   100   100   ---    Old_age   Always       -       0
    192 Power-Off_Retract_Count 0x0032   100   100   ---    Old_age   Always       -       1
    193 Load_Cycle_Count        0x0012   100   100   ---    Old_age   Always       -       16
    194 Temperature_Celsius     0x0002   229   229   ---    Old_age   Always       -       24 (Min/Max 22/27)
    196 Reallocated_Event_Count 0x0032   100   100   ---    Old_age   Always       -       0
    197 Current_Pending_Sector  0x0022   100   100   ---    Old_age   Always       -       0
    198 Offline_Uncorrectable   0x0008   100   100   ---    Old_age   Offline      -       0
    199 UDMA_CRC_Error_Count    0x000a   200   200   ---    Old_age   Always       -       0
    223 Load_Retry_Count        0x000a   100   100   ---    Old_age   Always       -       0
    
    SMART Error Log Version: 1
    No Errors Logged
    
    SMART Self-test log structure revision number 1
    No self-tests have been logged.  [To run self-tests, use: smartctl -t]
    
    
    SMART Selective self-test log data structure revision number 1
     SPAN  MIN_LBA  MAX_LBA  CURRENT_TEST_STATUS
        1        0        0  Not_testing
        2        0        0  Not_testing
        3        0        0  Not_testing
        4        0        0  Not_testing
        5        0        0  Not_testing
    Selective self-test flags (0x0):
      After scanning selected spans, do NOT read-scan remainder of disk.
    If Selective self-test is pending on power-up, resume after 0 minute delay.
    

  • SATAのAHCIポートを使う場合は、

# ./smartctl -T permissive -d sat,12 -s on /dev/rdsk/c4t0d0p0
# ./smartctl -T permissive -d sat,12 -a /dev/rdsk/c4t0d0p0
smartctl 5.42 2011-10-20 r3458 [i386-pc-solaris2.11] (local build)
Copyright (C) 2002-11 by Bruce Allen, http://smartmontools.sourceforge.net

=== START OF INFORMATION SECTION ===
Model Family:     Hitachi Travelstar 5K500.B
Device Model:     Hitachi HTS545050B9A300
Serial Number:    101126PBN403M7CPXP3E
LU WWN Device Id: 5 000cca 67cc9f775
Firmware Version: PB4OC64G
User Capacity:    500,107,862,016 bytes [500 GB]
Sector Size:      512 bytes logical/physical
Device is:        In smartctl database [for details use: -P show]
ATA Version is:   8
ATA Standard is:  ATA-8-ACS revision 6
Local Time is:    Sun Nov 27 10:27:24 2011 JST
SMART support is: Available - device has SMART capability.
SMART support is: Enabled

=== START OF READ SMART DATA SECTION ===
SMART overall-health self-assessment test result: PASSED

General SMART Values:
Offline data collection status:  (0x00) Offline data collection activity
                                        was never started.
                                        Auto Offline Data Collection: Disabled.
Self-test execution status:      (   0) The previous self-test routine completed
                                        without error or no self-test has ever
                                        been run.
Total time to complete Offline
data collection:                (  645) seconds.
Offline data collection
capabilities:                    (0x5b) SMART execute Offline immediate.
                                        Auto Offline data collection on/off support.
                                        Suspend Offline collection upon new
                                        command.
                                        Offline surface scan supported.
                                        Self-test supported.
                                        No Conveyance Self-test supported.
                                        Selective Self-test supported.
SMART capabilities:            (0x0003) Saves SMART data before entering
                                        power-saving mode.
                                        Supports SMART auto save timer.
Error logging capability:        (0x01) Error logging supported.
                                        General Purpose Logging supported.
Short self-test routine
recommended polling time:        (   2) minutes.
Extended self-test routine
recommended polling time:        ( 158) minutes.
SCT capabilities:              (0x003d) SCT Status supported.
                                        SCT Error Recovery Control supported.
                                        SCT Feature Control supported.
                                        SCT Data Table supported.

SMART Attributes Data Structure revision number: 16
Vendor Specific SMART Attributes with Thresholds:
ID# ATTRIBUTE_NAME          FLAG     VALUE WORST THRESH TYPE      UPDATED  WHEN_FAILED RAW_VALUE
  1 Raw_Read_Error_Rate     0x000b   100   100   062    Pre-fail  Always       -       0
  2 Throughput_Performance  0x0005   100   100   040    Pre-fail  Offline      -       0
  3 Spin_Up_Time            0x0007   152   152   033    Pre-fail  Always       -       2
  4 Start_Stop_Count        0x0012   100   100   000    Old_age   Always       -       77
  5 Reallocated_Sector_Ct   0x0033   100   100   005    Pre-fail  Always       -       0
  7 Seek_Error_Rate         0x000b   100   100   067    Pre-fail  Always       -       0
  8 Seek_Time_Performance   0x0005   100   100   040    Pre-fail  Offline      -       0
  9 Power_On_Hours          0x0012   090   090   000    Old_age   Always       -       4697
 10 Spin_Retry_Count        0x0013   100   100   060    Pre-fail  Always       -       0
 12 Power_Cycle_Count       0x0032   100   100   000    Old_age   Always       -       77
191 G-Sense_Error_Rate      0x000a   100   100   000    Old_age   Always       -       0
192 Power-Off_Retract_Count 0x0032   100   100   000    Old_age   Always       -       16
193 Load_Cycle_Count        0x0012   099   099   000    Old_age   Always       -       14476
194 Temperature_Celsius     0x0002   229   229   000    Old_age   Always       -       24 (Min/Max 18/36)
196 Reallocated_Event_Count 0x0032   100   100   000    Old_age   Always       -       0
197 Current_Pending_Sector  0x0022   100   100   000    Old_age   Always       -       0
198 Offline_Uncorrectable   0x0008   100   100   000    Old_age   Offline      -       0
199 UDMA_CRC_Error_Count    0x000a   200   200   000    Old_age   Always       -       0
223 Load_Retry_Count        0x000a   100   100   000    Old_age   Always       -       0

SMART Error Log Version: 1
No Errors Logged

SMART Self-test log structure revision number 1
No self-tests have been logged.  [To run self-tests, use: smartctl -t]


SMART Selective self-test log data structure revision number 1
 SPAN  MIN_LBA  MAX_LBA  CURRENT_TEST_STATUS
    1        0        0  Not_testing
    2        0        0  Not_testing
    3        0        0  Not_testing
    4        0        0  Not_testing
    5        0        0  Not_testing
Selective self-test flags (0x0):
  After scanning selected spans, do NOT read-scan remainder of disk.
If Selective self-test is pending on power-up, resume after 0 minute delay.

メモ

  • Disk I/O: iostat -cxt 1
  • なにから確認しなきゃいけないかなー。というただのメモ。
    • 機能
      • ZFS
        • rpoolのミラーによる障害対応テスト
          • メインストレージサーバで試すには、稼働が本格化し過ぎた為。
          • GT110bがAHCI使えなくて、オンボードSATAがホットスワップ出来ない。致命的。
        • v13からv28へのsend/recv
        • Deduplication
          • アニメ100GB/250GB/500GB/1TBテスト?
          • vmstat/iostat/zpool iostatをぶん回して長期安定試験出来るかな?
            • dedupratioの変遷も見るべきなので、zpool get all poolも見ないと。
              • 毎分取得位でも十分かなぁ。
              • 性能系じゃないしね。
            • dtrace...orz
            • 事前ログとして取得すべきものがいくつかあるはず。
          • dedup状態における読み出し性能試験もやりたいよね。
      • COMSTAR相互接続: Hyper-V, ESXi, windows 7
    • 性能(検証方法検討中)
      • ZFS
      • RAID0構成: 1,2,3,4,5,6,7,8台
      • RAID1構成: 2,3,4台
      • RAID10構成: 2,4,6,8台
        • 定常時, DEGRADED * 1,2,3,4台
      • RAIDZ構成: 3,4,5,6,7,8台
        • 定常時: 実質的には、4,6,8の3点テストでいい気がする)
        • DEGRADED * 1台
      • RAIDZ2構成: 4,5,6,7,8台
        • 定常時(実質的には、4,6,8の3点テストでいい気がする)
        • DEGRADED * 1,2台
      • RAIDZ3構成: Pending
      • COMSTAR: device, device slice, zvol, file

資料


最終更新日: 2021-05-22 14:40:40